如何解決Ajax Control Toolkit 7.123 的 jQuery 1.9.1 required 例外

當更新至最新版的Ajax Control Toolkit後,我發現debug console多出了許多錯誤,其中最主要的就是"jQuery 1.9.1 required"。我一開始以為是因為我在head載入的是1.10.2,所以將其改為1.9.1,但是錯誤依然存在。且檢查網頁原始碼,當中仍然有載入1.10.2版的jQuery。

上網找了一下,最後發現如果將ToolkitScriptManager.EnableCDN設為true,它會自己載入1.10.2版…. =.= ,所以只要設為false,即使網頁有另外載入不同版本的jQuery,也不會再有例外發生。

來源

廣告

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com 標誌

您的留言將使用 WordPress.com 帳號。 登出 /  變更 )

Google+ photo

您的留言將使用 Google+ 帳號。 登出 /  變更 )

Twitter picture

您的留言將使用 Twitter 帳號。 登出 /  變更 )

Facebook照片

您的留言將使用 Facebook 帳號。 登出 /  變更 )

w

連結到 %s